KParts::ComponentFactory to namespace?
hausmann at kde.org
Sun May 27 01:32:26 BST 2007
On Sunday 27 May 2007 01:50:59 Alex Merry wrote:
> Is it OK to make KParts::ComponentFactory into a namespace, to stop
> anyone trying to instantiate it?
> It just has five static template methods and, given the existence of
> KParts::Factory, I can't imagine that there'll be any need to make it
> into a real class at any point.
It used to be a namespace because of a compiler bug in gcc 2.96 IIRC. But
since we don't support that compiler anymore anyway (KDE's minimum is at
least gcc 3.3) I agree with changing it to a namespace.
P.S.: Nice cleanups in kdelibs!
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 189 bytes
Desc: This is a digitally signed message part.
More information about the kde-core-devel