meinproc4 broke? ("version `GLIBCXX_3.4.5' not found")

Matthew Woehlke mw_triad at
Tue May 22 23:08:51 BST 2007

Thiago Macieira wrote:
> Matthew Woehlke wrote:
>> Ok, last I checked it isn't Monday... everyone else can build kdelibs,
>> right? I'm getting this:
> Right.
>> /usr/lib/ version `GLIBCXX_3.4.5' not found (required by
>> /usr/local/kde-trunk-svn/lib/
> This is not caused by KDE, but by your own system.

Well, /something/ changed and the only thing I changed was KDE. So I'm 
trying to figure out why what worked before stopped working when I 
upgraded KDE.

> Your (part of Strigi) was compiled against one 
> version of that had version GLIBCXX_3.4.5. That version is 
> now gone from libstdc++.
> Recompile or undo the up/downgrade you did to libstdc++.

I haven't touched gcc/libstdc++ since setting up my KDE4 environment.

>> $ /usr/bin/gcc --version # shouldn't be used?
>> gcc (GCC) 3.4.3 20050227 (Red Hat 3.4.3-22.1)
> That's probably the reason why it's failing. You're using that g++ which 
> is too old. It's causing your programs to link to too old a libstdc++.

$ which gcc

Trust me, that's the compiler being used :-) (it's gcc 4.1.2 as 
previously indicated). The problem is that for some reason things aren't 
using the libstdc++ that goes with the gcc I'm using. Any ideas why?

I'm guessing what happened is that previously the system libstdc++ was 
"usable", and something changed in strigi that it suddenly needs the 
newer libstdc++.

Anyway I've worked around it for now by adding 
/usr/local/kde/gcc4/lib/gcc/i686-pc-linux-gnu/4.1.2 to my 
LD_LIBRARY_PATH, but I'm still confused as to *why* I need to do this.

"Nobody expects the traditional Bourne shell!"

More information about the kde-core-devel mailing list