3.5.6 'make check' problems... LOTS of them

Matthew Woehlke mw_triad at users.sourceforge.net
Wed Jan 31 19:09:54 GMT 2007

I had a number of failures running 'make check' on a pristine 3.5.6 
kdelibs (I am building on another box over ssh with X forwarding enabled).

First, dcop/tests/test.cpp couldn't find test.h. I noted that this seems 
to have been fixed in trunk (at least, google found comments to that 
effect); the rule to generate test.h is not being run before trying to 
build test.cpp. Fixed by 'make -k check', and oddly, now I can't 
reproduce it even after 'make clean' (in dcop/tests).

Next: the dcop check fails because dcopserver is not being run. 
Auto-start it please! And auto-STOP it when done. Worked around by 
running 'dcopserver' and then killing it later.

Next: something (didn't pay attention what) didn't build because it 
couldn't link to a lib (kdetestutil I think? something like that?). 
Fixed by doing 'make install'. PLEASE DON'T MAKE 'make check' NEED 'make 
install' FIRST!

Next: kio/tests does REALLY badly on the mimetype test. First /root 
failed (because my /root is 750 and I am running as a user that gets to 
use the group permissions). Fixed by chmod 700'ing /root, but this 
indicates that the test assumptions are flawed. Then trash:/ gave the 
icon '(null)'. Not sure why on this one. At this point I gave up and 
disabled the test.

Finally, KATE's regression tests fail; the instructions for running them 
want HTTPS svn access which I don't have. Why can't ordinary users run 
this test? (*I* have an svn+ssh account, but why should I need one to 
run 'make check'?) I tried anonsvn; it failed with a '302 FOUND'(??).

OFFICER throws a tear gas grenade at you. You start to feel nauseous. 
You need fresh air quickly.
Sorry, I have a philosophical objection to Microsoft products.

More information about the kde-core-devel mailing list