naming (Re: KInstance redesign)
kretz at kde.org
Tue Jan 30 12:14:26 GMT 2007
On Tuesday 30 January 2007 13:00, Hans Meine wrote:
> On Tuesday, 30. January 2007 12:22, Matthias Kretz wrote:
> > > > > name suggestion: KComponentData
> > >
> > > What about KComponentInfo? IMHO "Data" sounds more like document
> > > contents, ... than like the components' metadata like author, website,
> > > ...
> > OTOH, info sounds a little like it's optional, but the object is very
> > integral to the correct workings of some application/component setups.
> > E.g. the KStandardDirs object or the KSharedConfig object. Those two
> > objects don't fall into the category of information, no?
> You are right - how about KComponentConfig or KComponentSetup then?
> Nah, I don't like these any more than KComponentData either.
> Err, is KComponent taken? (Not as a class name, is it?)
I believe the name KComponent is too general. Because this object is not the
component itself only data for/of the component.
Matthias Kretz (Germany) <><
MatthiasKretz at gmx.net, kretz at kde.org,
Matthias.Kretz at urz.uni-heidelberg.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the kde-core-devel