naming (Re: KInstance redesign)
hans_meine at gmx.net
Tue Jan 30 12:00:05 GMT 2007
On Tuesday, 30. January 2007 12:22, Matthias Kretz wrote:
> > > > name suggestion: KComponentData
> > What about KComponentInfo? IMHO "Data" sounds more like document
> > contents, ... than like the components' metadata like author, website,
> > ...
> OTOH, info sounds a little like it's optional, but the object is very
> integral to the correct workings of some application/component setups. E.g.
> the KStandardDirs object or the KSharedConfig object. Those two objects
> don't fall into the category of information, no?
You are right - how about KComponentConfig or KComponentSetup then?
Nah, I don't like these any more than KComponentData either.
Err, is KComponent taken? (Not as a class name, is it?)
Ciao, / /
/ / ANS
More information about the kde-core-devel