New kdelibs/kutils/kpluginselector

Tobias Koenig tokoe at
Thu Nov 2 16:17:27 GMT 2006

On Wed, Nov 01, 2006 at 02:12:22PM +0100, Rafael Fernández López wrote:
> Hi guys,
Hi Rafael,

> Waiting for your comments ;)
Looks really good, but here comes the nitpicker comments ;)

1) The 'catname' parameter of addPlugins should be renamed to something
   more meaningfull (categoryName is fine as well)

2) insertKCM: we should keep in mind to remove/replace the 'KCM' when
   the KCM classes have been removed

3) The private slots and methods should be moved to the private class to
   keep the public API as clean/small as possible.

Greate work otherwise!

Separate politics from religion and economy!
The Council of the European Union is an undemocratic and illegal institution!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the kde-core-devel mailing list