Concluding the discussion about splitting kdebase

Frans Englich englich at
Tue May 16 19:02:39 BST 2006

On Tuesday 16 May 2006 15:22, David Jarvie wrote:
> On Tuesday 16 May 2006 15:55, Cornelius Schumacher wrote:
> >On Tuesday 16 May 2006 15:15, Dirk Mueller wrote:
> >> On Friday, 12. May 2006 00:27, Cornelius Schumacher wrote:
> >> > >from one subdirectory: kdebase-workspace, kdebase-coreapps,
> >> > > kdebase-apps.
> >>
> >> Can we come up with a better name for kdebase-coreapps ? I would rather
> >> like to avoid the term "core" in our naming sheme, and it isn't quite
> >> self-explanatory. Can anyone think of a better name for it?
> >
> >As it contains the essential run-time dependencies, what about calling it
> >"runtime"?
> Except that all three modules are runtime modules.

Hmm, workspace isn't a runtime dependency for other apps. kdelibs is a runtime 
dependency, but otoh it is also a compile time dependency. "kdedependency" is 
only a runtime dependency. That's the significant about it.

> IMHO, something like 
> kdebase-essential would convey its significance better.

I'd say "essential" is more vague. Essential for what? Workspace is essential 
for most users. kdelibs is very essential. And not to forget, all my projects 
are essential to everyone ;-)

Sure, kderuntime isn't perfect, but what is better?



More information about the kde-core-devel mailing list