KCM rename

Michaël Larouche michael.larouche at kdemail.net
Wed Jul 19 12:14:03 BST 2006

Le July 19, 2006 05:02, Matthias Kretz a écrit :
> Hi,
> as KCModule and friends are not bound to KControl anymore I believe a
> rename of the classes is in order. In Trysil Aaron and Ben said to call
> everything KSettings:
> KCModule -> KSettingsModule or KSettingsPlugin
> KCModuleInfo -> KSettingsInfo(rmation)
> KCModuleProxy -> KSettingsWidget
> KCMultiDialog -> KSettingsDialog
> KSettings::Dialog -> KSettingsDialog
> KSettings::CompontentsDialog -> KSettingsDialog
> KCModuleContainer -> KSettings(Module|Plugin)Container
> Another obvious name would be to use Config, but KConfig is already taken.
> I'm not satisfied with the name change yet and before I'd tackle such a
> drastic change I'd like to hear some more opinions.

I'm for it. I always found that weird that some classes in kdelibs was tied to 
KControl, because of the name.

Michaël Larouche
KDE developer working on Kopete, Gamefu(KDE), Solid...on dial-up :P
Website: http://www.tehbisnatch.org/
MSN/Email: michael.larouche at kdemail.net
IRC: irc.freenode.org/DarkShock on #kopete,#solid,#gamefu,#plasma
Jabber: darkshock at myjabber.net

More information about the kde-core-devel mailing list