KCM rename

Matthias Kretz kretz at kde.org
Wed Jul 19 10:02:13 BST 2006


as KCModule and friends are not bound to KControl anymore I believe a rename 
of the classes is in order. In Trysil Aaron and Ben said to call everything 
KCModule -> KSettingsModule or KSettingsPlugin
KCModuleInfo -> KSettingsInfo(rmation)
KCModuleProxy -> KSettingsWidget
KCMultiDialog -> KSettingsDialog
KSettings::Dialog -> KSettingsDialog
KSettings::CompontentsDialog -> KSettingsDialog
KCModuleContainer -> KSettings(Module|Plugin)Container

Another obvious name would be to use Config, but KConfig is already taken. I'm 
not satisfied with the name change yet and before I'd tackle such a drastic 
change I'd like to hear some more opinions.

Matthias Kretz (Germany)                            <><
MatthiasKretz at gmx.net, kretz at kde.org,
Matthias.Kretz at urz.uni-heidelberg.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20060719/0f3984eb/attachment.sig>

More information about the kde-core-devel mailing list