KStandardDirs::checkAccess, ::mkdir, etc

Michel Hermier michel.hermier at gmail.com
Thu Jul 6 11:37:01 BST 2006


2006/7/6, Friedrich W. H. Kossebau <Friedrich.W.H at kossebau.de>:
> Am Donnerstag, 6. Juli 2006 11:07, schrieb Stephan Kulow:
> > Hi!
> >
> > I looked at the header of KStandardDirs and I wonder if someone
> > has a good name for the namespace of the non-standard dir functions
> > that happened to move into it.
> >
> > I'm talking about ::mkdir, ::checkAccess, ::exists, ::realPath
> > and ::realFilePath (even though I wonder why would need two functions
> > for that)
> >
> > The suggestions on #kde4-devel were KDirHelper and KFileSystem. What
> > do you think?
>
> KFileSystem of course.
>
> KFileSystem::mkdir( "NewDir" );
> KFileSystem::checkAccess( theFile );
> KFileSystem::exists( theFile );
> KFileSystem::realPath( whatever );
>
> Looks natural, makes sense, IMHO.
>
> Regards
> Friedrich
>

Looks natural, but won't that limit us to have KFileSystem represent
the *native* file system ?
Doesn't it make more sence to have a singleton returning a
QAbstractFileEngine child, instead of static functions ?




More information about the kde-core-devel mailing list