KStandardDirs::checkAccess, ::mkdir, etc

Friedrich W. H. Kossebau Friedrich.W.H at kossebau.de
Thu Jul 6 10:32:42 BST 2006

Am Donnerstag, 6. Juli 2006 11:07, schrieb Stephan Kulow:
> Hi!
> I looked at the header of KStandardDirs and I wonder if someone
> has a good name for the namespace of the non-standard dir functions
> that happened to move into it.
> I'm talking about ::mkdir, ::checkAccess, ::exists, ::realPath
> and ::realFilePath (even though I wonder why would need two functions
> for that)
> The suggestions on #kde4-devel were KDirHelper and KFileSystem. What
> do you think?

KFileSystem of course. 

KFileSystem::mkdir( "NewDir" );
KFileSystem::checkAccess( theFile );
KFileSystem::exists( theFile );
KFileSystem::realPath( whatever );

Looks natural, makes sense, IMHO.


More information about the kde-core-devel mailing list