[RFC] KLockFile

Thomas Braxton brax108 at cox.net
Thu Sep 22 17:09:58 BST 2005


Hi,
I was looking to change KLockFile::LockOptions to a QFlags. I wanted some 
feedback on changing the names of the options.
I want to go from
enum LockOptions {
LockNoBlock = 1, LockForce=2
};

to
enum LockOption {
NoBlock=1, Force=2
};
Q_DECLARE_FLAGS(LockOptions, LockOption)

which IMO is cleaner, and more type safe.




More information about the kde-core-devel mailing list