[PATCH] New KFileItem::assign() for Optimizing KDirListerCache
brade at kde.org
Fri Mar 25 14:10:06 GMT 2005
On Friday 25 March 2005 14:58, David Faure wrote:
> OK - can we name it something else than assign, though, to remove some
> possible confusion?
Hm... if you think so, sure.
> How about load? setData? update?
> update() sounds best I guess. This is about updating the data in an
> existing kfileitem.
But I don't use it to update the item (which can also be confused with
refresh) but rather to make it an entirely new item... The method is a
shortcut for 'delete item; item = new KFileItem( udsEntry ... );'. Any better
name suggestions? Maybe setNewData, assignNewData? Hm, I'm not completely
happy with any of those yet...
Michael Brade; KDE Developer, Student of Computer Science
|-mail: echo brade !#|tr -d "c oh"|s\e\d 's/e/\@/2;s/$/.org/;s/bra/k/2'
KDE 3: The Next Generation in Desktop Experience
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the kde-core-devel