Default Preferences != Default Preferences

Ali Akcaagac aliakc at
Wed Mar 2 18:32:27 GMT 2005

KDE 3.4.0-RC1

I detected quite a bunch of quirks, that I really like to see solved
pretty soon, so please accept my comment as constructive feedback that
should animate you people to talk about it for a bit. Its aim is to help
improving KDE for the future and make it become a even better Desktop
Environment, than it already is. Most of what I have written here has
been filed as bugreport or whishes to KDEs bugzilla but till now the
paid attention for it was quite low. Now, let us start:

When KDE gets started for the very first time, it's in a undefined state
(so I call it). Assuming your homedir is totally empty and you enter
startx from your console to load inside KDE, you get prompted with a
bunch of dialogs and wizard that I under normal circumstances skip.

I usually seek over to the Control Center as most other people may be
doing and start pressing 'default' with each listed capplets/plugins
entry that is there. So going to Background, pressing 'default', going
to Panel, pressing 'default' and what I detect here is that most
capplets/plugins don't use the default values as one might initially

You see CheckBoxes changing state, you see Sliders jumping to a
different position, you see Text entries or numeric values changing once
you press 'default'. You can reproduce this anytime you start KDE for
the first time in a empty homedir and then going to Control Center and
moving through all the stuff and simply pressing 'default'. This is
usually what I do first when starting KDE newly, to give the default
settings some sort of fixed condition. Now that KDE use KConfigXT, which
uses some sort of schemas files (as under GNOME) I ask myself why
default != default ?.

With the recent changes quite a few options were hidden under a separate
'Advanced Options' Button which pops up a new dialog for KDE these
dialogs usually don't respond on the main capplets/plugins dialog
'default' Button and thus can not be reset to a predefined default
state. Why ?

Another thing is that quite a few capplets/plugins don't have a
'default' Button at all or don't show the Apply/Reset Button once
'default' has been pressed - making these capplets/plugins interact
differently than other capplets/plugins.

What I have seen too is that, when you press 'default' in for example
the Keyboard capplet/plugin then it sets the correct 'default' values
but once you head over to the Accessibility Keyboard capplet/plugin and
you press 'default' there, that it changes behavior or values of the
Keyboard capplet/plugin where I pressed 'default' before. E.g. globally
spoken there are capplets/plugins (even other ones) that change the
default state of a capplet/plugin that has been set to default before.
E.g. changing Checkboxes, changing Sliders, changing Numeric or Text

Simply try this and you figure out that I am right. You can verify this
with any KDE 3.x version released so far.

What I detected too (and this is reported as well to bugzilla) is that
if you start a bunch of applications for the very first time, that they
interact strangely with the Window Manager or the entire Desktop
Environment. For example you start the KBookmarksEditor for the first
time. You see it popping up in full windowed mode ? Why ? The Button top
right is not showing a 'maximized state'. But you need to press it once
and then again and you see that the KBookmarksEditor takes a normal size
which it probably was aimed to have once started for the first time.
This tells us that the first time values when started are not really
applied to these applications. There are more of those within a full KDE
installation. Why ?

Icons on the Desktop are quite often misplaced when KDE gets restarted
and you need to place them correctly again. Why ?

After setting the KDE default values for the first time and then
starting the applications for the first time, to give them a condition
and default settings, I played with the Fonts settings in the Control
Center again. I realized that from one second to another my entire Anti
Aliasing support didn't work anymore as it worked before. I pressed the
Anti Aliasing button. reapplied the settings, quit KDE and started it
again. Same result no Anti Aliasing. I pressed 'default' applied it,
left KDE and started it again. Still no Anti Aliasing. Why ? Libraries
are not missing, fonts all there. Only a setting issue within KDE to not
handle conditions or things correctly.

When KDE get's started for the very first time and assuming that
the /tmp dir is empty. KDE creates (no, it's XOrg or XFree actually) two
directories named '.ICE-unix' and '.X11-unix'. They both belong to the
user who started it. Though they should belong to root. GNOME handles
that stuff correctly KDE somehow not. Why ? Bug for this has been
reported long time ago.

To sum the things up. KDE is quite a nice Desktop Environment and the
amount of work floating into it can be seen, the work spent and the time
investigated are immense. Though my feeling is that the 'settings' stuff
isn't getting the right care as it should specially when leaving
applications and desktop elements in a 'undefined' state when started
for the very first time. I would really appreciate if more care would
flow into this area because correct settings and correct default values
for the first time started are needed. Assuming a really bad scenario.
Say a new user gets created and he starts KDE for the first time then a
'undefined state' may result into buffer overflows due to wrong values
assumed or taken or even may crash applications or the entire Desktop.

I hope I was able to make clear what I was up to and hope I could point
you people to a critical area that needs some care. When replying to me
personally please CC to me since I am not subscribed here.

More information about the kde-core-devel mailing list