Richard Smith kde at
Wed Nov 3 20:13:18 GMT 2004

On Wednesday 03 November 2004 19:56, Olivier Goffart wrote:
> Le Mercredi 3 Novembre 2004 20:35, George Staikos a écrit :
> > On Wednesday 03 November 2004 14:41, Richard Smith wrote:
> > > Why not instead consider KopetePassword for inclusion in kdelibs (after
> > > a rename, of course)? Only the wallet folder name is Kopete-specific
> > > (that's hard-coded in in kopetewalletmanager.cpp).
> Yes, it's what i'm trying to do with that.
> But KopetePassword has several things that are kopete specific.  the
> KWallet thing is one thing,   but also the KConfig stuff.

It wouldn't be hard to make the wallet folder name application-defined. Or to 
add a flag to say whether the KConfig fallback is allowed. Apart from the 
synchronous stuff, I can't think of anything you could remove and still have 
it do enough for Kopete.

More information about the kde-core-devel mailing list