Runaway QSlider : it's a Qt bug

Guillaume Laurent glaurent at
Tue Mar 9 23:05:08 GMT 2004

On Monday 08 March 2004 10:16, Lubos Lunak wrote:
>  Actually I think the general rule rather should be: do not use misleading
> or wrong names. ExcludeSocketNotifiers ignores socket notifiers events, but
> keeps them pending. The same for the hidden ExcludeTimers. But
> ExcludeUserInput doesn't really exclude user input (at least according to
> what my dictionary says 'exclude' means), it discards it -> it should be
> either fixed to do what it says, or it should be called DiscardUserInput.

I agree with your point, however what is even less intuitive here (at least to 
me) is the idea that the mouseRelease event will be discarded because I just 
want to keep the GUI properly refreshed. That said it makes sense once you 
realize how it works, but not at first :-).


More information about the kde-core-devel mailing list