David Faure faure at
Mon Jun 7 23:46:07 BST 2004

On Tuesday 08 June 2004 00:38, Oswald Buddenhagen wrote:
> setup() is ok with me. setupGUI() sounds redundand to me, given that
> KMainWindow is a GUI element itself, well, _the_ GUI element.

Behind the createGUI and kxmlgui* names, we imply that GUI == menubar/toolbars/statusbar,
whereas the contents of the mainwindow is, well, the main widget, not included
in that "gui" name. But setup() is fine (just more chances to hit some 'overriden virtuals'
problems in kmainwindow-derived classes, setup() being such a generic name).

David Faure, faure at, sponsored by Trolltech to work on KDE,
Konqueror (, and KOffice (

More information about the kde-core-devel mailing list