patch: create non existent directories
Felix Berger
bflat1 at gmx.net
Thu Dec 30 00:20:13 GMT 2004
Hi,
the applied patch is basically copy-paste from konq_diroperations.cc.
It enables KDiroperator::mkdir() and KDirSelectDialog::slotMkdir() to suggest
a non existent folder name for local files.
The only thing I replaced in the konq_diroperations code was:
- if (access(QFile::encodeName(url.path()), F_OK) == -1)
+ if (!KIO::NetAccess::exists( url, false, 0 ))
I didn't want to include <unistd.h>, I don't know if it's ok to depend on it
there.
I don't really like the code duplication, at least KFileDialog and
KDirSelectDialog could/should share some code there. What do you think?
Felix Berger
--
Use Debian GNU/Linux!
http://www.felix.beldesign.de/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: create_non_existent_folder.patch
Type: text/x-diff
Size: 3080 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20041230/5fe6f061/attachment.patch>
More information about the kde-core-devel
mailing list