[patch] reading from stdin in KWrite
bastian at kde.org
Mon Jun 2 10:48:30 BST 2003
-----BEGIN PGP SIGNED MESSAGE-----
On Monday 02 June 2003 10:37, Daniel Stone wrote:
> On Mon, Jun 02, 2003 at 12:42:44AM +0200, Scott Wheeler wrote:
> > The biggest part of this patch is a s/katePart/m_katePart/ since I needed
> > to add a method called katePart() and since the m_ is used on other
> > member variables this seemed like the way to go.
> Given that studlyCappedVariables seems to be standard in most KDE apps,
> why_did_you_descend_into_underscore_hell? IMO, mKatePart is very easy to
> read, whereas m_katePart just looks ugly. Surely we don't need to mix
> and match two naming styles? It feels to me like mixing and matching
> spaces and tabs as a method of indentation.
You seem to be poorly informed. The m_ prefix is widely used throughout KDE to
indicate that the variable is a class member.
bastian at kde.org -=|[ SuSE, The Linux Desktop Experts ]|=- bastian at suse.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org
-----END PGP SIGNATURE-----
More information about the kde-core-devel