[PATCH] New configDialogSize() and saveDialogSize() methods

Christian Loose christian.loose at hamburg.de
Tue Jan 21 22:49:01 GMT 2003


Am Dienstag, 21. Januar 2003 23:37 schrieb Simon Hausmann:
> On Tue, Jan 21, 2003 at 11:26:29PM +0100, Christian Loose wrote:
> > Am Sonntag, 19. Januar 2003 18:20 schrieb Christian Loose:
> > > Am Sonntag, 19. Januar 2003 18:09 schrieb Waldo Bastian:
> >
> > [snip]
> >
> > > > Can you let the old saveDialogSize() function call this new one so
> > > > that there is less code duplication? I guess that applies to
> > > > configDialogSize() as well.
> > >
> > > No problem for configDialogSize() (see attached patch) but what about
> > > the global option of saveDialogSize()? This doesn't make much sense for
> > > the variant with KConfig*, does it?
> >
> > Okay, okay! :-)
> >
> > How about this one? Is this patch acceptable?
>
> Any opinion on my thoughts regarding passing a KConfig reference
> instead of a pointer?
>
> Simon

You are right. I forgot to answer your question. Sorry!

I don't know. Most methods return a pointer to KConfig like KGlobal::config() 
etc. So if you changed it to passing a KConfig reference instead, you would 
have to call it like this

configDialogSize( *config, "Dialog" );

instead of

configDialogSize( config, "Dialog" );

Also what happens if config is null?

Christian








More information about the kde-core-devel mailing list