Looking for a better name
kretz at kde.org
Thu Aug 28 20:00:16 BST 2003
On Thursday August 28 2003 20:33, David Faure wrote:
> Would it make sense to use
> - KConfigDialog
> - KConfigDialogDispatcher
> - KConfigDialogPlugin[Page]
> or is that too long?
It is long, but since almost all editors support completion it's not that
I was thinking about that name KConfig... myself, but I didn't like the
association with the KConfig class.
And another thing to consider: The KConfigureDialog class is not an actual
dialog (in the sense of being a widget shown on screen) but only creates one
internally. Perhaps that should be reflected in the class name, but I don't
think that Factory or Proxy would fit here.
Matthias Kretz (Germany) <><
MatthiasKretz at gmx.net, kretz at kde.org,
Matthias.Kretz at urz.uni-heidelberg.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
More information about the kde-core-devel