Looking for a better name
kretz at kde.org
Thu Aug 28 19:19:23 BST 2003
since a few days there are some new classes in kdelibs/kutils to standardize
configuration dialogs in KDE. Now I'm not satisfied with the names of those
classes and Cornelius even less :-)
So this is a plea for help in finding good names that also describe what those
The names I used so far:
KConfigureDialog is the dialog that appears when pressing on "Configure
MyApp..." in the Settings menu.
KCDDispatcher is a singleton that tells the components of the app when they
should reread their configuration.
KCDPluginPage is a baseclass for plugin pages in the config dialog.
KSelectEntriesDialog is not in CVS yet and is really hard to explain. :-) It
is opened inside the config dialog to select which components of the app
should be enabled/disabled. It looks a little like a KDialogBase TreeList
dialog but the TreeList is used for selecting the components that should be
active. The page on the right is used to show a description of the component.
PS.: In case you didn't realize KCD=KConfigureDialog - and many people
immediately think of a CD player or a K change directory :-)
Matthias Kretz (Germany) <><
MatthiasKretz at gmx.net, kretz at kde.org,
Matthias.Kretz at urz.uni-heidelberg.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
More information about the kde-core-devel