QT 3.1 needed

David Faure david at mandrakesoft.com
Tue Oct 22 14:47:41 BST 2002

Hash: SHA1

On Tuesday 22 October 2002 15:23, Nicolas Goutte wrote:
> As always without warning, a change in KDE has an effect in KOffice.
> QT 3.1 is needed.
> I am tired of such discussions but why can the developement version of KOffice 
> not work on the last stable KDE version? Is it so hard?
> It is hard enough to work with problems of an unstable KOffice, I do not need 
> problems with an unstable KDE and even less problems with a brand new QT.

I agree with you, I'm not too happy with the choice of _requiring_ Qt 3.1 either.
But you're taking it to the wrong list - there's nothing koffice-devel can do about
the core decision of requiring Qt-3.1.

The reasoning was that: if everyone uses Qt-3.1-current we'll see its bug earlier, 
and get them fixed before Qt-3.1-final. However this assumes everyone is working
on kdelibs/kdebase, and that's far from the case.

I guess a solution would be that kdelibs and kdebase require Qt-3.1, but the
other modules don't. This way, people who _update_ kdelibs and kdebase
have to use Qt-3.1, but those who only update koffice (and keep kde-3.0.x's
kdelibs&kdebase), can keep developing koffice with a stable kde & qt installed.
Same with kdenetwork etc.

Hmm, OTOH we wouldn't have noticed the setClipRegion bug if nobody was
testing koffice with Qt-3.1-beta2....

- -- 
David FAURE, david at mandrakesoft.com, faure at kde.org
Contributing to: http://www.konqueror.org/, http://www.koffice.org/
Get the latest KOffice - http://download.kde.org/stable/koffice-1.2/
Version: GnuPG v1.0.7 (GNU/Linux)


More information about the kde-core-devel mailing list