Build system

Alex Zepeda zipzippy at
Thu Jun 20 07:44:01 BST 2002

On Wed, Jun 19, 2002 at 05:16:17PM +0200, Rolf Magnus wrote:

> And a lot more of them. It seems as if I get those 4 lines once for every 
> in the package. I tried automake version 1.5 and version 1.62, 
> but both give the same error.
> For some packages (e.g. kdebase and kdeutils) it works, for others (e.g. arts 
> and kdelibs) it doesn't.

What version of autoconf do you have installed?

blarf:~#pkg_info -Ia|grep auto
autoconf-2.53       Automatically configure source code on many Un*x platforms
autoconf213-2.13.000227_1 Automatically configure source code on many Un*x platforms
automake-1.5,1      GNU Standards-compliant Makefile generator
automake14-1.4.5    GNU Standards-compliant Makefile generator (legacy version

As crazy as that looks, basically autoconf 2.53 and automake 1.5 are being
used by KDE (the older versions have binaries installed as autoconf123 and
automake14, and wouldn't be used by default).

So far just (via a small shell script):

gmake -f Makefile.cvs (okay, so you can probably use straight up make)

Have you updated the admin directories for the various modules all at the
same time?

is what works here (FreeBSD-CURRENT, gcc 3.1).  Yeah, I'm suprised it
works too, given that gcc 3.1 really does put a computer into a funk.

- alex

More information about the kde-core-devel mailing list