[kde-community] Tupi: Open 2D Magic

Thomas Zander zander at kde.org
Tue Aug 27 14:22:25 UTC 2013


On Tuesday 27 August 2013 15.58.05 Sune Vuorela wrote:
> On 2013-08-27, Thomas Zander <zander at kde.org> wrote:
> > KDE does not prefer v2 over v3, so the sentence above is a bit
> > confusing to me.
> > See also;
> > http://techbase.kde.org/Policies/Licensing_Policy
> > point 5 includes the "or later" part.
> 
> erm. you reading is wrong. Let me emphazise some bits.
> 
> |  * GPL version 2 as listed in kdelibs/COPYING or later
> |  * GPL version 2 or version 3 or later versions approved by the
> |  
> |     membership of KDE e.V.
> | 
> | Note each bulletpoint above is a single option, it can not be licenced
> | under just part of one bulletpoint option
> 
> this means that you have to choose between those lines, not choose part
> of it, e.g. the 'or later' part only.

Ah, Sune, thanks for the mail. I guess I expressed myself poorly.

My mail was essentially to make sure that Tupi now is GPLv2-or-later, as 
opposed to GPLv2-only.
Which means having the "or later" words in the license header of each file.

I guess my mail could be read differently, so I hope this makes it clearer;
In KDE we prever v2+. Or in other words, we prefer v2-or-later. Which the 
document I linked indeed specifies like Sune pointed out.

-- 
Thomas Zander



More information about the kde-community mailing list