Qt static libraries - pkgconfig again

Ch.Ehrlicher at gmx.de Ch.Ehrlicher at gmx.de
Fri Feb 23 08:08:59 CET 2007

Von: Thiago Macieira <thiago at kde.org>
> Christian Ehrlicher wrote:
> >pkg-config on win32 is a bad idea... :(
> If you want to compile KDE with Qt 4.3, you'll need it.
> kdelibs does not build because QtUiTools is missing a dependency when 
> linking kjsembed.
Can't we get around this problem by convincing the trolls to not make it a static lib? Or by parsing the .prl-files. Can't qmake tell us what deps we need?
What depenency is missing? I need to compile qt4.3 on win32 to see if we really need to add this dependency - can you tell me more what's missing?

The directory layout on win32 does not allow a pkg-config tool as every program has it's own subdirectory without a common place for .pkg-config - files. We've enough problems with other external libs/tools on win32 - adding another one would just rise the level for new devs once more :(

Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer

More information about the Kde-buildsystem mailing list