Problems with uic / cmake (missing -L kde_widgetdir)

Michael Biebl mbiebl at
Thu Aug 31 17:26:40 CEST 2006

2006/8/31, Thomas Baumgart <ipwizard at>:
> On Thursday 31 August 2006 00:09, Michael Biebl wrote:
> [...]
> > It seems, that the autogenerated *.cpp file is missing a ktextedit.h
> > include. After investigating the problem, I found that autotools
> > contains a m4 macro:
> > KDE_CHECK_UIC_FLAG(L,[/nonexistent],ac_uic_supports_libpath=yes,ac_uic_supp
> >orts_libpath=no) On Debian this means that autotools calls uic with the
> > parameter "-L /usr/lib/kde3/plugins/designer".
> The parameter -L tells uic to look in the said directory for widget libraries.
> The libs contain - among others - the information which "#include <xxx>" line
> should be generated for the widgets contained in the libs. If this
> information (path to directory containing libs) is missing while uic is
> running, the scenario you describe shows up.

This is more or less clear to me. My point is, that kde3uic.cmake
should be fixed and pass -L `kde-config
--prefix`/lib/kde3/plugins/designer as parameter to uic which it
currently does not.

> You mentioned that you run the failing make in a chroot jail. Do you still
> have access to the $(KDEDIR)/lib/kde3/plugins/designer directory there? This
> directory has to contain the file.

The files are there. The problem seems to be, that when I run uic
under my normal user account it seems to look for the *.so files in
/usr/lib/kde3/plugins/designer by default, but if I run uic in the
chroot I explicitely have to tell uic too look for the plugins in
/usr/lib/kde3/plugins/designer. Dunno why uic behaves differently in
these two environments. Does uic normally read a config file or
something alike?


More information about the Kde-buildsystem mailing list