[Kde-bindings] KDE/kdebindings/ruby/qtruby
Davor Ocelic
docelic at spinlocksolutions.com
Thu Dec 11 16:31:49 UTC 2008
On Thu, Dec 11, 2008 at 07:50:54AM -0500, Davor Ocelic wrote:
> ....
>
> - RSTRING(rs)->len into RSTRING_LEN(rs) and the likes
> - s/rb_frame_last_func/rb_frame_callee/
>
> For the KCODE & UTF thing I'm not sure, but I suppose the other
> two could be taken care of with a simple define and/or version
> check to do the right thing.
For the defines, I mean something simple, in fact the same thing
that narray library does:
#if !defined RSTRING_LEN
#define RSTRING_LEN(a) RSTRING(a)->len
#endif
#if !defined RSTRING_PTR
#define RSTRING_PTR(a) RSTRING(a)->ptr
#endif
#if !defined RARRAY_LEN
#define RARRAY_LEN(a) RARRAY(a)->len
#endif
#if !defined RARRAY_PTR
#define RARRAY_PTR(a) RARRAY(a)->ptr
#endif
And then of course they can always just use RSTRING_LEN() etc..
I'll prepare a patch with this in the next few days, test with
1.8 and 1.9 and send it to the list.
Cya,
-doc
More information about the Kde-bindings
mailing list