Is there a project that is jovie successor? (fwd)

Jeremy Whiting jpwhiting at
Tue Oct 26 15:29:02 BST 2021

On Tue, Oct 26, 2021 at 8:09 AM Gustav Degreef <gustav97 at> wrote:

> Hi Jeremy,
> Deeply appreciate your time and effort, but no luck.
>   user:~/QtSpeech/hello_speak> qmake-qt5
> Info: creating stash file /home/user/QtSpeech/hello_speak/.qmake.stash
> Project ERROR: Unknown module(s) in QT: texttospeech

Ok, from that it seems you don't have the -devel package needed to build
things against QtSpeech. For that install the following:

sudo zypper install libqt5-qtspeech-devel

Then you should be able to build hello_speak.

But since speech-dispatcher itself doesn't have the problem (spd-say didn't
duplicate) the problem is either in Okular's use of QtSpeech (not likely,
it's one line that calls QtSpeech) or QtSpeech itself. On my test vm I've
only got the speechd plugin for QtSpeech in
On your machine do you have a flite plugin there also from some package
from 15.0 or 15.1 times maybe (I don't see any flite plugin package in 15.2
repos, but maybe you got it before upgrading).

I took another look at QtSpeech code itself though and I don't see any way
it would ever use more than one plugin or send the text to multiple
plugins. Then I took a look at the speechd plugin again and it definitely
only sends the text it gets to spd_say function once. I think the next
thing to try will be to enable debugging in speech-dispatcher (after we are
sure that's what plugin QtSpeech is using) and see what text it's getting
to synthesize from okular. I'll write up some instructions for that once I
do it here and remember how it's done :)


user:~/QtSpeech/hello_speak> make
> make: *** No targets specified and no makefile found.  Stop.
> Since your opensuse VM is working fine, I doube checked my
> installations.  I have a 17 inch laptop and a 13 inch old one that I use
> for traveling.  Both machines have a main partition opensuse 15.2 and a
> "test" partition with opensuse 15.3.  3/4 of these installations have
> the duplicate voices in Okular and Kmouth. Only 1 15.3 installation is
> having a normal speech output in Ojular.  All 4 installations are
> upgraded systems (from previous opensuse 15.0, 15.1 and prior releases.
> So none of them is a "clean" install like your VM.
> I tried building it on each laptop, but the same result.   You were
> reight at the beginnig, it's turning out quite difficult to track down.
> Any other suggestions?
> If all else fails, I'll do a clean install of 15.3 on one of these 4
> partitions.
> Thanks, Gustav.
> Truncating the rest to get past mailing list size limit without approval.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the kde-accessibility mailing list