Quick survey: func(..) {..} versus (..) {..}

Samuel Gaist samuel.gaist at edeltech.ch
Fri Jul 25 21:19:25 UTC 2014


+1,

I'd rather have to read and write more if that makes the code easier to understand.

On 25 juil. 2014, at 16:10, Jay Woods <woodsjaya at gmail.com> wrote:

> Definitely with func.
>  
> In the future, it can always be made optional (for use by the novice and pretty print).
> 
> 
> On Fri, Jul 25, 2014 at 9:58 AM, Aaron J. Seigo <aseigo at kde.org> wrote:
> Quick question time!
> 
> How do you feel this:
> 
> =======
> myFunction()
> {
>         let Bar = func() { true; }
>         Bar();
> }
> 
> receiver func(PID, $auth, message) { ... }
> =======
> 
> compares to this:
> 
> =======
> myFunction()
> {
>         let Bar = () { true; }
>         Bar();
> }
> 
> receiver (PID, $auth, message) { ... }
> =======
> 
> 
> for readability and clarity?
> 
> 
> Pros of func():
>         * makes it clear that this is a function declaration
> 
> Pros of ():
>         * no reserved words
>         * less typing and reading
> 
> --
> Aaron J. Seigo
> _______________________________________________
> Funq-devel mailing list
> Funq-devel at kde.org
> https://kde.org/mailman/listinfo/funq-devel
> 
> 
> _______________________________________________
> Funq-devel mailing list
> Funq-devel at kde.org
> https://kde.org/mailman/listinfo/funq-devel



More information about the Funq-devel mailing list