Quick survey: func(..) {..} versus (..) {..}

Jay Woods woodsjaya at gmail.com
Fri Jul 25 14:10:46 UTC 2014


Definitely with func.

In the future, it can always be made optional (for use by the novice and
pretty print).


On Fri, Jul 25, 2014 at 9:58 AM, Aaron J. Seigo <aseigo at kde.org> wrote:

> Quick question time!
>
> How do you feel this:
>
> =======
> myFunction()
> {
>         let Bar = func() { true; }
>         Bar();
> }
>
> receiver func(PID, $auth, message) { ... }
> =======
>
> compares to this:
>
> =======
> myFunction()
> {
>         let Bar = () { true; }
>         Bar();
> }
>
> receiver (PID, $auth, message) { ... }
> =======
>
>
> for readability and clarity?
>
>
> Pros of func():
>         * makes it clear that this is a function declaration
>
> Pros of ():
>         * no reserved words
>         * less typing and reading
>
> --
> Aaron J. Seigo
> _______________________________________________
> Funq-devel mailing list
> Funq-devel at kde.org
> https://kde.org/mailman/listinfo/funq-devel
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://kde.org/pipermail/funq-devel/attachments/20140725/a1645b7f/attachment.html>


More information about the Funq-devel mailing list