[FreeNX-kNX] Re: Problem running KDE applications in rootless sessions on Ubuntu 10.04 LTS (Lucid Lynx)

Alastair Johnson alastair at solutiontrax.com
Wed Mar 2 17:20:13 UTC 2011

On Wednesday 02 March 2011, Stefan Baur wrote:
> [KDE apps from KDE4 terminating NX session unexpectedly; no such issues
> with KDE3]
> > That has been the case for many years, since before KDE 3.x IIRC
> > For example, just run:
> > konqueror
> > And you will find that the command returns almost immediately.
> That I knew... but still, rootless NX worked with KDE3 applications in
> Debian Lenny (using the freenx packages for ubuntu intrepid on the server).
> It seems to be broken in Ubuntu 10.04 LTS, which uses KDE4 (and a newer
> set of freenx packages).
> > Now, maybe my assumption is wrong and this is not the source of the
> > problem described above.
> Seems to be a different reason.
> Any ideas? Anyone able to verify my experience?

I haven't tried rootless with KDE4 yet. Some wild speculation follows... There 
have been problems in the past with kde sessions when distros changed the way 
they started sessions. NX would still be using the 'old' method, and would be 
missing some vital step so session would fail, while local sessions worked 
just fine. I wouldn't be surprised if the rootless startup was missing some 
step that the full session startup has, such as starting a dbus session bus, 
setting or changing an environment variable or something. 

More information about the FreeNX-kNX mailing list