[FreeNX-kNX] Problem with freenx (APPLICATION_LIBRARY_PRELOAD has invalid value).

Ozarov, Arie ozarov at a2z.com
Thu Apr 2 21:30:07 UTC 2009


After installing freenx on my RHEL 3.0 and trying it I figured out that I can't use it.
The client always times out and gives the following error:

NX> 203 NXSSH running with pid: 5480
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.4.0
NX> 134 Accepted protocol: 1.4.0
NX> 105 login
NX> 101 User: ozarov
NX> 102 Password:
NX> 103 Welcome to: ozarov.desktop.amazon.com user: ozarov
NX> 105 listsession --user="ozarov" --status="suspended,running" --geometry="1600x1200x32+render" --type="unix-default"
NX> 127 Sessions list of user 'ozarov' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: ozarov
NX> 105 startsession  --virtualdesktop="1" --link="lan" --backingstore="1" --encryption="1" --cache="128M" --images="512M" --media="0" --session="ozarov.desktop" --type="unix-default" --cookie="******" --geometry="fullscreen" --kbtype="pc102/en_US" --screeninfo="1600x1170x32+render"

NX> 1000 NXNODE - Version 1.4.0-44 OS (GPL)
NX> 700 Session id: ozarov.desktop.amazon.com-1001-D379A7F60CC811A18A6BB4D2E5A58CD9
NX> 705 Session display: 1001
NX> 703 Session type: unix-default
NX> 701 Proxy cookie: 508d218fd97ba5d47f649d1183407813
NX> 702 Proxy IP:
NX> 706 Agent cookie: 4160dc5d5a50bb6109c7b7fbee43534c
NX> 704 Session cache: unix-default
NX> 707 SSL tunneling: 1
/usr/bin/nxserver: line 1041: 30216 Terminated              ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
NX> 105 NX> 504 Session startup failed.
NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1
NX> 1001 Bye.
NX> 280 Exiting on signal: 15

On the server side I could not see anything in the logs, nxserver.log , (I guessed I was not looking at the right places) but when running the check command
I get the following error:

/var/log> sudo /usr/bin/nxserver --start
NX> 100 NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 500 ERROR: Service already running
NX> 999 Bye
/var/log> sudo nxloadconfig --check
Error: Invalid value "APPLICATION_LIBRARY_PRELOAD=/usr/lib/libX11.so.6.2:/usr/lib/libXext.so.6.4:/usr/lib/libXcomp.so.1:
Warning: Invalid value "COMMAND_START_CDE=cdwm"
         Users will not be able to request a CDE session.

  Errors occured during config check.
  Please correct the configuration file.

Any idea what is wrong and how I can fix it?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/freenx-knx/attachments/20090402/48bc0fa5/attachment.html>

More information about the FreeNX-kNX mailing list