[FreeNX-kNX] Is nxagent still broken on amd64?

Bernard Cafarelli voyageur at gentoo.org
Mon Jul 7 16:08:47 UTC 2008

On Mon, 7 Jul 2008 11:24:08 -0400, Mike Kasick <mkasick-nx at club.cc.cmu.edu>
> Is that strictly so?  I just tried using the older library and agent
> versions (3.2.0-1 and 3.2.0-5 respectively) specified in the nx-3.2.0-r1
> ebuild, and I'm getting the exact same error.
> Might it be a latent bug that's triggered only with more recent
> This is a Debian sid amd64 machine with gcc 4.3.1 and libc 2.7.

I've just tested with nx 3.1, it fails the same way now indeed. And,
switching to gcc 4.2.4 (and latest 3.2 tarballs), I got a working nxagent
(well at least it shows a black window and does not fail on "core

So I stand corrected, this is rather a GCC problem...

>> nxagent from Free Edition does not seem to be affected though, both were
>> updated recently by NoMachine:
>> http://www.nomachine.com/news-read.php?idnews=240
> I pulled nxagent from the nxnode package and dropped it in place of the
> existing binary.  It appears to work, at least with the "nxnode --agent"
> test (haven't had time to check further).
> I suppose I could use this as a stop-gap solution.  Is there any
> difference
> between No Machine's nxagent and the one compiled from source?  I imagine
> there shouldn't be (modulo whatever difference triggers the error).
> Still, this irks me.

Apparently they do not use gcc-4.3 ;)

Bernard Cafarelli (Voyageur)
NX and GNUstep Gentoo developer

More information about the FreeNX-kNX mailing list