[FreeNX-kNX] FreeNX, NX-1.5.0 and nxc client libraries

LROUFAIL at nc.rr.com LROUFAIL at nc.rr.com
Thu Sep 1 15:31:38 UTC 2005

I have used nxrun with the nomachine 1.5 server and it has worked.

Please run nxrun with the command line option -l ide and post the 


-------------- next part --------------

I'm going to be working on kNX to port it to the nxc client libraries and 
generally make it more polished.

In order to familiarise myself with the NX system, I tried to connect to my 
server using the nxrun command-line client. The server is an AMD64 machine 
with NX-1.5.0 installed (which I compiled in a 32-bit chroot), and works fine 
with the commercial NoMachine 1.5.0 client.

When I try to get nxrun to connect to the server using the client 
configuration generated by the 1.5.0 client, it simply hangs on the "I> 
Initializing X protocol compression." step.

nxproxy says the following on the connection (it seems to log it to the client 
configuration file...):

Warning: Cookie mismatch in the authentication data.
Info: End of session requested by remote proxy. 
Info: Shutting down the link and exiting.

nxserver.log says the following:

NX> 701 Proxy cookie: 841f2ebf587d7cfd18e7f14830b55b91
NX> 702 Proxy IP:
NX> 706 Agent cookie: f7db982bd007fb7b3f168dc23aacb24b

I originally had this problem with NX 1.5.0 and FreeNX with the NoMachine 
1.5.0 client until I enabled the option "ENABLE_1_5_0_BACKEND" in node.conf. 
I figured that as the nxc client library is identifying as 1.4.0, I'd disable 
the option again. However, I still get the same error.

Are there any tips on what to do for this?

Many thanks,


George Wright, http://www.gwright.org.uk
KDE Developer - http://www.kde.org
-------------- next part --------------
FreeNX-kNX mailing list
FreeNX-kNX at kde.org

More information about the FreeNX-kNX mailing list