schema update to V 14 failed

jdd at jdd at
Sun May 14 16:45:04 BST 2023

Le 14/05/2023 à 12:52, Maik Qualmann a écrit :
> The update tries to create the "modificationDate" column in the "Albums" table,
> but it already exists. The cause is unclear, the digiKam4.db was already used
> with a newer digiKam version? The update has already been aborted and
> restarted?

many times, but always with the very same result (I can create a new 
database, so it's only an update problem, not a basic digikam one)

> Install SQLiteBrowser, open digiKam4.db, go to Albums table and delete
> modificationDate column.

well, seems impossible. whatever system I try I get an error

with sqlitebrowser I get this messagebox

but I may have done things wrong, its not at all obvious (and stack 
overflow don't help :-()

I have sqlite3 and a cli command would be the best thing

 > sqlite3 ALTER TABLE "Albums"."digikam4.db" DROP COLUMN modificationDate
Error: in prepare, near "TABLE": syntax error
   ^--- error here


> Maik
> Am Sonntag, 14. Mai 2023, 12:11:35 CEST schrieb jdd at
>> Hello,
>> I recently moved to openSUSE Tumbleweed (from openSUSE 15.3) and digikam
>> don't works anymore.
>> my computer is an asus tuf 706iu amd+nvidia gaming one
>> to make things simpler, I will speak of digikam appimage 8.0.0, but I
>> have the same result with my distribution version or any 7.7, 7.8 or 7.9
>> appimage version.
>> I can open a bug on kde bugtracker, but I'm not familiar with it and
>> maybe here the problem may seems easy to fix.
>> in short, digikam don't start. I get a message (in french, tranlated
>> approx) "can't update shema from 13 to 14"
>> on the terminal I have among other things:
>> "Digikam::CoreDbAccess::checkReadyForUse: Core database: cannot process
>> schema initialization"
>> and with:
>> export QT_LOGGING_RULES="digikam*=true"
>> I get a long error log (in the text file below)
>> any hint?
>> thanks
>> jdd

c'est quoi, usenet?

More information about the Digikam-users mailing list