bookworm killed digikam import

gene heskett gheskett at
Mon Jun 26 17:30:08 BST 2023

On 6/24/23 15:53, Maik Qualmann wrote:
> I suspect that the gvfsd-gphoto2 service is running in Gnome Desktop and is
> blocking the USB port and no longer releasing it. digiKam does not use a kio*
> or gvfsd* service and requires direct access to the USB port. Problem has been
> reported several times. Disable the desktop service.
But you didn't tell me how.

I killed, with htop, something that had gphoto2 in its name, but that 
has not restored my access to import from the camera, and it was not 
restarted by plugging in the camera and turning it on.

Then in ab additional msg you asked for a log, but didn't describe how 
to get it.

I did find a reference to ghoto2 in /etc/sane.d, and disabled the port 
line, but that apparently results in digiKam looking at a cache as the 
terminal its launched from now reports:
gene at coyote:~$ digiKam
-- digiKam Linux AppImage Bundle
-- Use 'help' as CLI argument to know all available options for digiKam 
-- Notes: to integrate this bundle to your desktop, use AppImageLauncher.
--        to enable all debug messages on the console, use 'export 
Check library
Check library
Check library
Check library
Check library
Check library
Check library
Check library
Check library
Check library
-- Preloading shared libs: 
locale_file_path.empty() for locale
locale_file_path.empty() for locale
locale_file_path.empty() for locale
QtAV 1.13.0(Jun 21 2022, 13:37:45)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) 
wbsecg1 at
Home page:
unknown: Unhandled container to remove :  Digikam::DigikamApp
Digikam::FreeSpaceWidget::kBAvail: Did not identify a valid mount point 
for ""
Digikam::ItemIconView::slotSelectAlbum: Unable to find album for 
corrupted double-linked list
/tmp/.mount_digiKaH9UKEL/AppRun: line 177: 159861 Aborted 
  (core dumped) digikam $@
but digiKam looked like it was running normally on screen so I didn't 
see that until I'd quit it.

While that file in /etc/sane.d/gphoto.conf looks like this:
# Interface port where the camera is connected
# This should be one of the values returned by "gphoto2 --list-ports",
# such # as serial:/dev/ttyS6 or usb:

# Port speed.  This should be one of the values returned by
# "gphoto2 --abilities"

# Name of camera.  This should be one of the values returned by
# "gphoto2 --list-cameras"
camera=Kodak DC240

# Prints some extra information during the init phase.

# The resolution should be the maximum resolution supported by the
# camera.  It's not really used for much, since the actual size will be
# reported by the camera when the download starts.  But it may be useful
# for the frontend to have a clue prior to the download.  (e.g. it
# may want to create an image window, or report the maximum file size.
# Width x Height.

# Thumbnail resolutions - ditto

# top-level (fixed) folder directory in camera.  Backend assumes
# that there is one variable directory under this (e.g. 100DC240)
# which will be read from the camera, and all the images in the
# camera are under that.
and gphoto2 --list-ports now reports:
root at coyote:/etc/sane.d# gphoto2 --list-ports
-bash: gphoto2: command not found
root at coyote:/etc/sane.d#
root at coyote:/etc/sane.d# gphoto2 --list-cameras
-bash: gphoto2: command not found
root at coyote:/etc/sane.d#

So its simply not possible to find the culprit using the info I have at 
hand. The only reference to gphoto2 I can find with grep -r in /etc, is 
in that sane.d subdir, which does not sound to me, to be a digiKam 
related file.  Is this a big secret and we have to tolerate windows like 
bs?? That bs is why there has only been one machine with windows on it 
and it got formatted for mandrake a week after I was forced to pay the 
M$ to get a lappy I could take on the road while doing broadcast 
consultant work for a few years after I retired from being the CE at 
WDTV-5 for the 19 years previous. I put mandrake on it because windows 
drivers for its broadcom radio didn't work ever, but mandrakes drivers did.

My hands however, are at your disposal, they have had a scope probe in 
one hand and a hot soldering iron in the other since 1948. You just have 
to tell me what to do.
> Maik
Thank you Maik.
> Am Samstag, 24. Juni 2023, 20:51:55 CEST schrieb gene heskett:
>> Greetings all;
>> running the appimage of 7.8 or 8.0, I've lost the ability to download
>> the pix I can see in my camera. Both worked flawlessly in debian
>> bullseye, but not since upgrading to bookworm. Do I have the wrong
>> appimage (the same one that worked in bullseye as /home is separate and
>> was not formatted during the bookworm install) now? Formerly xfce4, now
>> gnome since xfce4 and wayland have problems yet.  gnomes appearance has
>> improved a lot since I last tried it.
>> Suggestions please.  And thanks
>> Cheers, Gene Heskett.
> .

Cheers, Gene Heskett.
"There are four boxes to be used in defense of liberty:
  soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author, 1940)
If we desire respect for the law, we must first make the law respectable.
  - Louis D. Brandeis
Genes Web page <>

More information about the Digikam-users mailing list