Tags Failed to Write to Database

Maik Qualmann metzpinguin at gmail.com
Tue Aug 29 06:51:06 BST 2023

Note this addition we added to the description of how to create the database 
in digiKam-8.2.0:

NOTE: If you have problems with a MySQL server on Ubuntu, enter:

SET GLOBAL log_bin_trust_function_creators=1;

in the mysql prompt. To be able to create MySQL triggers.



Am Montag, 28. August 2023, 23:40:55 CEST schrieb Brandon Heinzelmann:
> I have Digikam 8.1.0 installed on Ubuntu 22.04 set up with MySQL 4
> databases.  The SQL user has full access to the databases.
> 1. digikam_db
> 2. digikam_thumbnails
> 3. digikam_face
> 4. digikam_similarity
> My issue is I get an error  'Failed to write to database' when creating
> tags. I have tried it on 4 other machines. Two Windows, one Mac and one
> Ubuntu 22.04. I tried it with SQLlite and it works so I know it's something
> with my database.
> This is a new setup and my first time using Digikam, but definitely not my
> first time using a computer.
> Any help is much appreciated.
> Thank you.
> Brandon

More information about the Digikam-users mailing list