unable to unset tag set externaly

Remco Viƫtor remco.vietor at wanadoo.fr
Thu Apr 6 14:07:14 BST 2023

On Thursday, 6 April 2023 13:19:04 CEST frederic chaume wrote:
> Hi all
> after the crash I had this week, I  have rebuild all my configuration ,
> but I have a remaining problem with the tag
> see the scenario below (done on a raw file and it was working well
> before the crash)
> - Set the tag in DXO => refresh the caption in DK, tag is seen correctly
> in DK
> - unset the tag in DXO => refresh the caption in DK but tag still
> visible in DK even if the tag is no more in the XMP sidecar file
> I tried multiple times and no change
> I have removed the XMP and tried again, same problem still happened
> in setting/metadata/advanced/tag the order I used is
> lr.hierarchicaltag
> dc.subject
> Digikam.TagList
> ...
> the flag "unify read and write " is set
> Any idea? thanks for your help
> regards
> Frederic
Assumption: when you say "tag" it's the Digikam (keyword) tag. 

Maybe digikam won't remove tags when they have disappeared from the sidecar?

Or when the XMP element where they are stored isn't in the sidecar? That could 
actually be considered a feature, as it would prevent losing information just 
because a poorly behaved other program doesn't conserve XML elements it 
doesn't understand.

Afaik, sidecars in Digikam are an extra, not an essential part of the data 
structure and storage. So the database is the standard, and modifications 
should be conservative..

More information about the Digikam-users mailing list