[digiKam-users] Problem with adding Collection Digikam 7.3.0 (Windows 10)

Michael McEllin mchlmclln at gmail.com
Sat Aug 7 11:08:24 BST 2021

Thanks for the advice - I guess cloning the disk may be the root of the issue. However, defining the collections as network shares did the trick. So I will probably leave well alone until I have another reason for reformatting disk.

Mark this one “customer satisfied” with very prompt and relevant guidance.


> On 6 Aug 2021, at 22:20, Maik Qualmann <metzpinguin at gmail.com> wrote:
> I don't know exactly where the error is without a DebugView log file from 
> digiKam.
> Two things:
> Virtual folders are be used under Windows to move the image folder from C: to 
> another drive. digiKam does not support virtual folders, you always have to 
> specify the physical path.
> It can happen that the drive UUID of the drives C: and D: are the same, then 
> digiKam cannot distinguish the drives. Either format a drive, it then receives 
> a new UUID or change the collection to a network collection in digiKam 
> settings, then only the path is used for identification. 
> Maik
> Am Freitag, 6. August 2021, 12:37:53 CEST schrieb Michael McEllin:
>> I recently installed version 7.3.0 of Digikam as the first installation of
>> Digikam on my computer. (In fact, I had just reloaded the operation system
>> so it was a “clean” computer.)
>> Installation was apparently trouble free and I could manipulate photographs
>> as expected, until I tried to add a new collection: I wanted to view images
>> in C:/users/Public/Pictures as a new collection but I get an error message:
>> “It was not possible to add a collection for the following paths:
>> C:/users/Public/Pictures “. In fact I cannot add any collection of images
>> stored on C:, always getting the same error message. In fact, in the
>> Collection configuration tool, the initial collection, which I had expected
>> to appear as C:/users/michael/Pictures was in fact described as
>> D:/users/michael/Pictures.
>> On further investigation, I find that although my Digikam database files are
>> created, as I specified, in C:/users/michael/Pictures, the Albums that are
>> actually loaded during the initial configuration are stored on another disk
>> D:/users/michael/Pictures. I have no problem in adding other collections
>> stored on D: .
>> At this point I need to point out that when reloading my operating system I
>> had retained a complete clone of the old OS and user files on a separate
>> hard disk, on which the bootable partition now appears to Windows as D:. In
>> the Windows Disk Management utility, the disk containing the old clone (D:
>> etc) is designated as Disk 0, while the disk with the new version of the OS
>> (C: etc) is designated as Disk 1. (Disk 1 is also a Raid pair - though it
>> appears to windows in every respect as a single hard disk.) Is it possible
>> that Digikam collection configuration is miss-translating from drive
>> letters with the assumption that Disk 0 will always be C:  ?
>> Am I right in believing that this may be a bug rather than a “feature”?

More information about the Digikam-users mailing list