[digiKam-users] Just over 100k photos - mysql internal or sqlite

Mark Otway mark at otway.com
Wed May 29 14:20:34 BST 2019

I've tried both. The photos are on the network share, but I've tried it
with a local Sqlite, a local mysql and a remote mysql. The performance is
unusable on all of them - 10+ minutes startup before I can start browsing
images, etc. And that's with auto-import at startup turned off.

On Wed, 29 May 2019 at 13:31, Gilles Caulier <caulier.gilles at gmail.com>

> Across the network, sqlite is not the problem, as you CANNOT store the
> database on a network file system. It must be in local. Only the collection
> can be on a remote storage.
> So the network bandwith usable to consult the collections is the real
> problem.
> With a remote Mysql, you use more bandwith with the database.
> Gilles Caulier
> Le mer. 29 mai 2019 à 14:27, Mark Otway <mark at otway.com> a écrit :
>> I found both sqlite and mysql were equally slow and painful with a
>> collection of 400k images which are stored across the network. ;)
>> On Wed, 29 May 2019 at 13:02, Gilles Caulier <caulier.gilles at gmail.com>
>> wrote:
>>> Hi,
>>> At home, my collection is over 250.000 files with sqlite. Database and
>>> files are stored on SSD and it's enough fast.
>>> GillesC aulier
>>> Le mer. 29 mai 2019 à 12:24, Dougie Nisbet <dougie at katsura.uk> a écrit :
>>>> Since I'm just starting out with digikam I thought this was the time to
>>>> experiment with migrating to mysql. On the configuration screen digiKam can
>>>> find the binary for mysql_install_db but not mysqld. mysqld is installed
>>>> and when I use 'find' to tell it that the binary is in /usr/sbin/mysqld it
>>>> looks promising.
>>>> However, trying to migrate the database gives the pop-up error window:
>>>> An error occurred during the internal server start.
>>>> Details: Could not start database initialiser.
>>>> Executable: mysql_install_db
>>>> Arguments: --datadir=/store1/images/.mysql.digikam/db_data,
>>>> --defaults-file=/tmp/.mount_digikaJbT7bS/usr/share/digikam/database/mysql-global.conf
>>>> Process error: Unknown error
>>>> and on the command line I see:
>>>> Digikam::DatabaseServer::processErrorLog: Arguments:
>>>> "--datadir=/store1/images/.mysql.digikam/db_data,
>>>> --defaults-file=/tmp/.mount_digikaJbT7bS/usr/share/digikam/database/mysql-global.conf"
>>>> Digikam::DatabaseServer::processErrorLog: Stdout: "Neither host 'office'
>>>> nor 'localhost' could be looked up with\n'/usr/sbin/resolveip'\nPlease
>>>> configure the 'hostname' command to return a correct\nhostname.\nIf you
>>>> want to solve this at a later stage, restart this script\nwith the --force
>>>> option\n\nThe latest information about mysql_install_db is available
>>>> at\nhttps://
>>>> mariadb.com/kb/en/installing-system-tables-mysql_install_db\n
>>>> <http://mariadb.com/kb/en/installing-system-tables-mysql_install_db%5Cn>
>>>> "
>>>> which is a bit off. resolveip is a command I didn't know existed but
>>>> running it returns a local IP address for my host.
>>>> Performance using sqlite seems ok, and at just over 100k images I'm
>>>> probably a borderline case so I thought I would try the mysql database
>>>> option out of curiosity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20190529/3f0fdae8/attachment.html>

More information about the Digikam-users mailing list