[digiKam-users] Fwd: Re: More fighting with DigiKam

James Orr jorr1948 at earthlink.net
Sat Apr 27 16:51:14 BST 2019

Responding to the observation that the DK database might be invalid or 
corrupt, I noted that it seems to include new photos as I add them. 
After reading a bit more about SQLite, it seemed to me that the next 
database step might be to VACUUM the dust and detritus. I looked in 
checked and unchecked all the other boxes except for PERFORM DATABASE 
CLEANING. The cleaning process was slow, so I worked on a CADD project 
for several hours. At some time during the interval, I noticed that DK 
no longer showed in the Task Bar.--OK, it's done.

When I finished the CADD project, I clicked on the DK destop icon and 
got an error message. When I searched for the DK exe program, it was 
missing. I had to reinstall DK.

Looking at database statistics, the database had been reduced in size by 
about half. Tags, Pick List, and Colors still do not function. The next 
step, I guess, is to rename the existing database (I also make a disk 
image of my system nightly). This would force DK to create a new 
database, I expect. I think this is a drastic step. Any better ideas 
before I actually do it?

James M. Orr 2705 E Sussex Way Fresno, CA 93726

-------- Forwarded Message --------
Subject: 	Re: [digiKam-users] More fighting with DigiKam
Date: 	Thu, 25 Apr 2019 22:38:13 +0200
From: 	Gilles Caulier <caulier.gilles at gmail.com>
To: 	James Orr <jorr1948 at earthlink.net>

In digikam log, i see also these :

00001207700.09667969[13528] SkypeBridge.exe Information: 0 :
00001208700.09771729[13528] 2019-04-25 11:57:08.514-07:00 [13528:001] 
[INFO] Keeping user active
00001209700.59759521[9772] PPLE [Informational] LIFECYCLE: OnResuming
00001210700.60040283[13528] SkypeBridge.exe Information: 0 :
00001211700.60357666[13528] 2019-04-25 11:57:08.659-07:00 [13528:079] 
[INFO] IdleStateTracker - SendSystemIdleStatusUpdateAsync sent isIdle = 

SkypeBridge perturb digiKam while running. This is the magic world of 
Windows and anti spyware / anti virus mess...

Gilles Caulier

Le jeu. 25 avr. 2019 à 22:34, Gilles Caulier <caulier.gilles at gmail.com 
<mailto:caulier.gilles at gmail.com>> a écrit :

    00000942460.23703003[9544] digikam.general: Tag 0x16068973e40 do not
    have a valid parent


    00001065461.62533569[9544] "INSERT INTO Tags (pid, name) VALUES( :a,
    00001066461.62533569[9544] Error messages: "Unable to fetch row"
    "UNIQUE constraint failed: TagsTree.id, TagsTree.pid" 19 1
    00001067461.62533569[9544] Bound values:  (QVariant(int, 1),
    QVariant(QString, "Color Label None"))
    00001068461.62533569[9544] digikam.dbengine: Error while executing
    DBAction [ "InsertTag" ] Statement [ "INSERT INTO Tags (pid, name)
    VALUES( :tagPID, :tagname);" ]
    00001069461.62542725[9544] digikam.database: Attempt to create tag
    properties for tag id 0
    00001070461.62728882[9544] digikam.dbengine: Failure executing query:
    00001071461.62728882[9544] "INSERT INTO Tags (pid, name) VALUES( :a,

    this error appear multiple time. It's abnormal. Sound like the
    database contents is invalid or corrupted.

    Gilles Caulier

    Le jeu. 25 avr. 2019 à 21:03, James Orr <jorr1948 at earthlink.net
    <mailto:jorr1948 at earthlink.net>> a écrit :

        I attached a DebugView log to this message.
        I use Zone Alarm for antivirus.

            ZoneAlarm Extreme Security version:
            ZoneAlarm license key: *****
            Vsmon version:
            Driver version:
            Antivirus engine version:
            Antivirus signature DAT file version: 1318666784

        I also use Malware bytes version, component package
        1.0.563, update package 1.0.10340

        James M. Orr 2705 E Sussex Way Fresno, CA 93726
        On 4/24/2019 9:31 PM, Gilles Caulier wrote:
>         Hi,
>         To understand where is the problem under your Windows 10
>         computer, please install the DebugView program from Microsoft
>         as explained here :
>         https://www.digikam.org/contribute/
>         DebugView will catch all low level debug messages generated by
>         digiKam while running (under Linuc these kind of traces are
>         printed on the console)
>         Just report the debug statements here to investiguate.
>         Q : did you use an Anti-Virus of your Windows 10 computer ?
>         Best
>         Gilles Caulier
>         Le jeu. 25 avr. 2019 à 02:01, James Orr
>         <jorr1948 at earthlink.net <mailto:jorr1948 at earthlink.net>> a écrit :
>             When I went through the process of adding the tag "Turkey"
>             I tried both options in the initial window (with and
>             without the initial "/". Neither was accepted.
>             James M. Orr 2705 E Sussex Way Fresno, CA 93726
>             On 4/24/2019 12:46 PM, Rob Dueckman wrote:
>>             James, do you have the slash "/" in the tag you are
>>             trying to add? If so, maybe try it without the slash.
>>             Like others, I have tagged thousands of photos with no
>>             issues. I even live dangerously and write all metadata
>>             back to the original files (not .xmp's) without any
>>             issues (so far).
>>             Rob
>>             On Wed, 2019-04-24 at 09:48 -0700, James Orr wrote:
>>>             Re-sending from my normal account.
>>>             James M. Orr 2705 E Sussex Way Fresno, CA 93726
>>>             -------- Forwarded Message --------
>>>             Subject: 	More fighting with DigiKam
>>>             Date: 	Tue, 23 Apr 2019 10:15:06 -0700
>>>             From: 	James Orr <jorr1948 at comcast.net>
>>>             <mailto:jorr1948 at comcast.net>
>>>             To: 	digikam-users-group--kde.org
>>>             <http://digikam-users-group--kde.org>
>>>             <digikam-users at kde.org> <mailto:digikam-users at kde.org>
>>>             I really do want to like and use DigiKam. It is getting
>>>             harder to succeed.
>>>             Several weeks ago, I asked about what to do when DigiKam
>>>             would not record and use Pick Labels and Color Labels. I
>>>             use Windows 10 on a very capable machine. I've upgraded
>>>             to a couple of git versions, and now to 6.1.0. I still
>>>             cannot get these features to work.
>>>             I'm now preparing to copy several thousand images
>>>             (prints and slides) I made in Turkey in 1985-1986. A
>>>             pick list would be very useful. I also want to tag
>>>             images with keywords to help me find the images I want
>>>             after they are all digitized. So, I tried simply to add
>>>             the word "Turkey" to no avail. I get a dialogue box that
>>>             tells me "An error occurred during tag creation" and"
>>>             /Turkey failed to add tag to database".
>>>             I think these are all related to database management.
>>>             I looking in my D:\Pictures folder and found this file
>>>             name: .~lock.digikam4.db# (dated in 02-2019) I renamed
>>>             it to .~lock.digikam4.db#.old. Nothing changed in my
>>>             attempt to add a tag.
>>>             So, I wonder what is next for me to do.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20190427/3e29ada9/attachment.html>

More information about the Digikam-users mailing list