[digiKam-users] [digiKam] Facebook integration with 5.9 (beta), Fuse issue

Andrey Goreev aegoreev at gmail.com
Thu Feb 22 02:12:58 GMT 2018

Make sure to install fuse and all dependencies then.You might also need to install squashfs 

Sent from my Samsung Galaxy smartphone.
-------- Original message --------From: Tac Tacelosky <tacman at gmail.com> Date: 2018-02-21  3:13 PM  (GMT-07:00) To: digiKam - Home Manage your photographs as a professional with the power of open source <digikam-users at kde.org> Subject: Re: [digiKam-users] [digiKam] Facebook integration with 5.9 (beta), Fuse issue 
I'm getting
tac at tac-xps13:~/Downloads$  ./digikam-5.9.0-20180217T042939-i386.appimage dlopen(): error loading libfuse.so.2
AppImages require FUSE to run. You might still be able to extract the contents of this AppImage if you run it with the --appimage-extract option. See https://github.com/AppImage/AppImageKit/wiki/FUSE for more information
When I run it with --appimage-extract, a bunch of files are extracted, but nothing happens, it just ends:
TODO: Implement inode.base.inode_type 10squashfs-root/usr/share/showfoto/breeze.rccTODO: Implement inode.base.inode_type 10squashfs-root/usr/share/showfoto/datasquashfs-root/usr/share/showfoto/data/banner-showfoto.pngsquashfs-root/usr/share/showfoto/data/logo-showfoto.pngsquashfs-root/usr/share/showfoto/data/splash-showfoto.pngsquashfs-root/usr/share/solidsquashfs-root/usr/share/solid/actionssquashfs-root/usr/share/solid/actions/digikam-opencamera.desktoptac at tac-xps13:~/Downloads$ 

I've followed the instructions on the github issue, too.
Although I've been using Ubuntu for a while, these permissions, mounting and group issues make me feel like a newbie!
On Wed, Feb 21, 2018 at 4:05 PM, Andrey Goreev <aegoreev at gmail.com> wrote:

If you get this error:

# fuse: failed to exec fusermount: Permission denied

check permissions of /usr/bin/fusermount:

# ls -lah /usr/bin/fusermount

If the output looks like this:

# -rwsr-x--- 1 root root 31K Jul 17 05:18 /usr/bin/fusermount

then run this command:

# sudo chmod +x /usr/bin/fusermount

to make permissions loke like this:

# ls -lah /usr/bin/fusermount
# -rwsr-x--x 1 root root 31K Jul 17 05:18 /usr/bin/fusermount

Best regards, 

On Wed, Feb 21, 2018 at 2:01 PM, Tac Tacelosky <tacman at gmail.com> wrote:
Thanks -- will 5.9 release require fuse?  If so, can you add more instructions, I've followed what I can, but am still stuck.  The other missing dependency (in 5.8) was actually pretty easy to install.
On Wed, Feb 21, 2018 at 2:42 PM, Gilles Caulier <caulier.gilles at gmail.com> wrote:

2018-02-21 14:46 GMT+01:00 Tac Tacelosky <tacman at gmail.com>:
I'm wondering if Facebook integration works better in 5.9 (beta), under Ubuntu 17.10
I tried to see for myself, but can't run the appimage because of a fuse error.
dlopen(): error loading libfuse.so.2
AppImages require FUSE to run. You might still be able to extract the contents of this AppImage if you run it with the --appimage-extract option. See https://github.com/AppImage/AppImageKit/wiki/FUSE 
I've tried to install Fuse following the instructions, and also the with --appimage-extract option, but no luck.  
The fuse component is used internally by AppImage to decompress and mount quickly in user sapce the virtual disk from the bundle.
If i'm not too wrong, fuse right is managed by user properties. Your account must be listed in fuse group from the system. This is how i use Kate AppImage 32 bits compiled by myself to use on embeded Linux CentOS 6 in my office. Typically, the account is just add to fuse group in /etc/groups. You must to be un-logged to see the changes take effect.

Any suggestions?  I've been contributing a bit to the flickr uploader (https://github.com/TheFox/flickr-cli) with the idea of eventually being able to use that script to upload to flickr via a queue, but would really like to simply be able to upload selected images via the integrated DigiKam tools.
The Facebook tool must be ported to OAuth2 to automatize the identification. We will have a student working on this project while this summer. He will also ports others webservice tools to OAuth2, as Google for ex.
A lots of changes are planed about webservice tools for next 6.0.0. This is a main goal from my pending tasks since a while : more Qt5 only implementations, available everywhere (editor, light table, showfoto), no run-time loading at startup, and a factored API in digiKam core. I will explain more details later in this room, after to publish the last 5.9.0 release planed in few weeks.
Gilles Caulier

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20180221/958aaada/attachment.html>

More information about the Digikam-users mailing list