Missing thumbnails, maybe digikam4.db involved

userfriendly at mailbox.org userfriendly at mailbox.org
Fri Feb 3 19:21:57 GMT 2017


i'm using digikam for a decade (!) now. I really like it :-)

My current version here is 5.2 from openSuse Leap 42.2.
I've also used 4.14 on another box (Leap 42.1) to see if the problem described below exists also (it does).

Problem description:

Unfortunately it seems that during a big tagging session (and maybe due to a fast shutdown of my laptop after closing digikam) the database is messed up something.

- All Images are stored in folder like: "images\year\year-month" or "images\year\year-month_special event", e.g.: "images\2015\2015-3_trip_to_grandparents"
- The digikam4.db, recognition.db and thumbnail.db are stored at "images\"
- I store the tags also in the files.
- Now the folders after "/images/2016/2016-02" won't show all thumbnails in digikam. E.g. "/images/2016/2016-03" contains 373 images but only 21 of them are shown.
- The images are perfectly viewable with dolphin, showfoto, gwenview,... They even show the correct tags.
- I've also checked the integrity and optimized the db (https://userbase.kde.org/Digikam/Check_Databas). No errors have been reported.
		sqlite3 -line digikam4.db 'pragma integrity_check;' -> "ok"
		sqlite3 -line thumbnails-digikam.db 'pragma integrity_check;' > "ok"
- I tried to delete the tumbnails.db and used the maintenance tools of digikam to recreate fingerprints, thumbnails and looking for new images. No change.
- I tried to recreate a folder: 
	- I made a new folder "/images/2016/2016-3_tripNEW" and imported images fromm a usb-stick.
	- Now every single image is visible
	- I tag the images and close digikam
	- I reopen digikam and I see all the thumbnails for a second or so while digikam is looking for new images. BUT directly after that most thumbnails disappear!
	- This results in the same missing (and the same few showing) images in both folders: the old "/images/2016/2016-3_trip" and "/images/2016/2016-3_tripNEW"
	- I dosen't help to delete "/images/2016/2016-3_trip" before starting with "/images/2016/2016-3_tripNEW"
	- So there is some kind of background-process recognising the old and new images as the same images (same fingerprints? hash in database?) and than running in the same issue of not displaying most of them (but not all of them).
I am somewhat frustrated now. What can I do?
Unfortunately I do not have a recent backup of the digikam4.db. I would loose a lot of hard tagging-work.

What to do now?

Fortunately (?) the problem starts with images starting at "/images/2016/2016-03". Older folders seem to be (still) correct. I've checked this quite extensively.

Is there a way to delete all references in the database starting from that folder?
Or even more rigorous: Delete every entry (tags, fingerprints, hash,...) containing images in the db with references starting from "/images/2016"?

How to achieve this? 
While I know that should be doeable using spl here, I've no idea how to do it, exept of opening the db in e.g. sqlbrowser.
If this works out I will only have to re-tag the last year. And if all references from 2016 are gone (in the database) there should be no 'automated loss' of thumbnails anymore (?)

Do you have any other ideas to solve this issue?

Thanks, Andreas

More information about the Digikam-users mailing list