[Digikam-users] Upgrade from 4.14 to 5.0 leaves database unusable

Jasper jasper.mackenzie at gmail.com
Thu Jul 21 06:18:19 BST 2016

Today I upgraded from 4.14 to 5.0 using the Ubuntu PPA 'philip5/extra'.
I started 5.0 and used the same DB settings as 4.14 (external MySQL), which
sort of went fine except I could see no images and there were many missing
I then tried 4.14 again, but this complains: 'digikam(27977)/digikam (core):
DBVersion not available! Giving up schema upgrading.'
Subsequently 5.0 gives the same complaint. I started 5.0 with a freshly
created DB and copied the missing 'settings' table to the old schema and
tried 5.0 with the old schema again. I still get the DBVersion error.

Nothing I can do solves this problem and I sort of need that DB 8)

Any ideas to:
 Firstly get 4.14 to work with the old DB again
 Secondly migrate the 4.14 DB successfully to 5.0

And note that the version of 5.0 that I installed did not have any icons
except geolocation on the right hand panel



View this message in context: http://digikam.1695700.n4.nabble.com/Upgrade-from-4-14-to-5-0-leaves-database-unusable-tp4687912.html
Sent from the digikam-users mailing list archive at Nabble.com.

More information about the Digikam-users mailing list