Migration from 4.14 to 5.0/5.1 does not work

Stephan Olbrich stephanolbrich at gmx.de
Thu Aug 11 21:31:08 BST 2016


I made some progress. The path was fine, but I had problems with the database, 
which got corrupted somehow. Not sure why digikam4 did work, probably because 
it didn't try to write to the db. Reading still seemed to work.
With a working backup of the database I tried the migration again. Now all 
images are shown. But what is still missing is the "unkown" face where all the 
faces which are marked but have no name attached to them yet. The data is 
still there in digikam4.
Btw. the database is now about 50MB, before it was about 30MB. Does digikam5 
store more data in the database? 


Am Mittwoch, 10. August 2016, 21:34:03 CEST schrieb Martin (KDE):
> Hallo
> I had a simmilar issue. I got it solved by changing the pathes in the
> digikam sqlite database. In the albumroots table of this database the path
> limiters (the "/" sign) in the identifier filed was wrong (something like
> %aa where aa is a number). Replacing the wrong one by a regular slash and
> digikam 5 can access all albums again.
> Regards
> Martin
> Am Mittwoch, 10. August 2016, 21:18:30 CEST schrieb Stephan Olbrich:
> > Hi,
> > 
> > I'm trying to migrate from 4.14 to 5.0 or 5.1
> > 
> > When I start digikam 5 (it doesn't matter if it is 5.0 or 5.1) I get the
> > first start assistant. I select the folder where my pictures and database
> > is. When digikam starts, it scans a while for new images. When this is
> > done
> > there are no albums in the album view. All tags from the database are
> > there, but no pictures are there if I select a tag.
> > All people tags are there as well, except the unknown tag for faces which
> > have no name assigned yet.
> > Each time I restart digikam it scans a while for new images but still
> > shows
> > no album or pictures.
> > If I delete the database before starting digikam (after deleting the
> > digikam 5 config to get a clean start), everything works fine. All images
> > are there, but obviously all the data which is only in the database is
> > missing.
> > 
> > Any ideas how to solve this issue?
> > 
> > Regards,
> > Stephan

More information about the Digikam-users mailing list