[Digikam-users] invisible images

Gian Paolo Sanino Vattier gpsanino at vtr.net
Sun Jun 7 04:11:48 BST 2015

Hi Boudewijn, that is the weird thing. The images are not RAW but JPG
(at least the majority f them), and it happens randomly. I have not been
able to see any difference between "invisible" and "visible images. We
go for a daily monitoring effort looking for dolphins, as you saw, and
from that set of photos, some are shown and other are not.
They are taken with Nikon cameras (d5100/d700, etc). In the past I
recall a problem with the embedded thumbnail from nikon, specially after
using the editor,  but that was solved long time ago.

If the embedded preview is broken, can it be ignored by "thumbnail view
mode" but seen by "table view mode"?
I tried to open the "invisible" images with the editor in an attempt to
rebuild its preview but the editor simply refuses to even open.

One trick... if I open one of these files from Table view, with
ShowPhoto, it not only opens but also allows me to edit it, and save it
as a new image. That image is seen by Digikam's thumbnail mode properly.
No idea why the editor does not do the same. But at least I found this

Just a side note (that I should post somewhere else): in case you use
the KDE:EXTRA repo in OpenSuSE (with the mos recent version of Digikam
and other applications), you may also use Lensfun library 0.3.0 or
previous. Among the lenses I use, is the Nikkor 55-300mm EG VR, that is
listed as known by Lensfun's library but somehow is not recognized (used
also by Digikam). To solve the problem, just open as "su" the file
/usr/share/lensfu/slr-nikon.xml, search for 55-300mm and then on the
model line (first line), erase the two characters "f/". Save and voilĂ .
Digikam (and other applications using lensfun) will now recognize from
metadata this popular lens and Digikam's editor will do its magic.

again, thanks a lot

On 06/05/2015 06:46 AM, Boudewijn wrote:
> On 4-6-2015 22:59, Gian Paolo Sanino Vattier wrote:
> > On 06/03/2015 12:28 PM, Johannes Kapune wrote:
> >> Am 03.06.2015 um 16:30 schrieb Gian Paolo Sanino Vattier:
> >>> Some of my old photos, not all of them and almost randomly, are not
> >>> visible on the thumbails mode.(...)  and this is happening
> >>> on all my five boxes (PCs and notebooks) and with the same images.
> >> maybe there is a problem with database - some thumbnails are missing.
> > So rebuilding the thumbnails, fingerprints and resync of the database,
>> does not result in making visible the "invisible images"...
>> Any other idea?
> Since it happens to the same images on all systems, it seems to me the
> problem is with the image (nice image, by the way :-) )
> Are they all RAW-images, with (supposedly) embedded jpg-thumbnails?
> Could it be that the embedded preview is broken, some way or another?
> If "rebuild thumbnails" makes a thumbnail of png and jpg, and copies
> the embedded preview of RAW, then that explains why you don't see
> anything (assuming that is the problem).
> Best regards,
> Boudewijn

More information about the Digikam-users mailing list