[Digikam-users] missing thumbnails - database cleanup???

Daniel Bauer linux at daniel-bauer.com
Tue Jan 6 15:13:30 GMT 2015

Am 06.01.2015 um 15:25 schrieb Daniel Bauer:
> Hello,
> from time to time digikam refuses to show thumbnails in the album view
> for some images. No idea why...
> Searching google I found that it might bbe nessesary to cleanup the
> databases. As I always have a lot of changes I can imagine...
> But I cannot find the cleanup_digikamdb.1 program as an rpm for
> opensuse. Big brother google doesn't help me, of course.
> Any hints?
> Daniel
> digikam 3.2.0
> sqlite db
> (ps: I even copied the missing image again under a new name, it is still
> not shown...)

I updated to digikam 4.6.0, no change
I run
	sqlite3 -line digikam4.db 'pragma integrity_check;'  and
	sqlite3 -line thumbnails-digikam.db 'pragma integrity_check;'
no errors
	sqlite3 -line digikam4.db 'vacuum;'
reduced size about 50%
	sqlite3 -line thumbnails-digikam.db 'vacuum;'
no vivible change in file size

however the thumbs of those images are still not shown.

There must be something in those images that digikam does not like 
(although they were produced with digikams batch tool). They wouldn't be 
shown in any other folder, no matter if I rename them. But when I open 
the fiole with gewenview and save a new copy, it is immediately shown...

I can send such an image to a developper, but not publish it...


Daniel Bauer photographer Basel Barcelona
room in Barcelona: https://www.airbnb.es/rooms/2416137

More information about the Digikam-users mailing list