[Digikam-users] My Digikam stopped re-reading metadata from files...

Gian Paolo Sanino Vattier gpsanino at vtr.net
Sat May 31 19:10:30 BST 2014

Hi, maybe somebody has a solution for this.

My DK 4.0.0 used to work fine on this but recently I am having a problem.
I am trying to clean some files metadata, and still getting some old
tags not deleted. In general, I just unselect the tags on the right pane
and apply, getting them out of the files. Tested it on DK 4.0.0 and it
worked but I wanted to try a faster way, more like in batch.

So, I tried for the first time with the new "tag manager", the tool
where it offers to remove the indicated tag from the files
containing it. It was faster than using combinations of filters and left
pane etc. And the progress bar below showed that something ws indeed
happening. However, I checked and the obsolete tags were still on the
metadata, and they were still there, in contrast with the previous
method that did the work but slowly.  And more worrisome, DK started
behaving weird:

*The main issue*: since then, my "re-read metadata from files" is
completely dead. It shows a progress bar as
always etc but no tags are added to the database's tag tree. I mean,
obsolete tags from the metadata, not present on the tag tree, to be
added into the database. They just do not show up anymore on the tree
despite how many times "re-reading the metadata".

*Efforts to solve it*:
- I have tried rereading the metadata from files, from album, and from
the entire collection, as well as using the mantainance tool. The
obsolte tags are not added to the database and therefore I cannot use
the old method to get rid of them.
- "reread from metadata" just stopped doing its job... The files are
fine, since I tested some of them in a small netbook with DK 3.5.0 and
it works well retrieving the tags from the files metadata.
- I tried duplicating a folder (album) externally and opening DK to see
if by scanning that new folder, it adds the tags from the metadata as
before or not. Files were added but their metadata not.
- I tried re-installing DK4.0.0, but no change.
- Tried with deleting the config Digikamrc and digikam's settings
folder, but nothing changed except the need to personalize KD again. I
ran out of ideas to try to re-enable the "reread metadata from images" tool.

I have libexiv2-11 and libexiv2-12. Version 0.24 is on libexiv2-13, I
was able to install it, but I cannot remove libexiv2-12 (v0.23) since
many dependencies would crash on my OpenSuSE 13.1 (x64). I do not know
if DK uses libexiv2-13 even if libexiv2-12 is installed too.

Anybody has an idea to check before going to a full re-installation of
my box?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20140531/bdd524ea/attachment.html>

More information about the Digikam-users mailing list