[Digikam-users] Help building on OS X

Viktor Hedefalk hedefalk at gmail.com
Sat Aug 2 22:27:17 BST 2014


I'm trying to get started with digiKam on OS X. I think the
instructions are a bit outdated and I could really use some help.

I first tried the macports installation. Everything went smoothly but
trying to start


it just crashes before any GUI is shown. I'll attach the thread dump.

However, I then noticed that this was an outdated version (3.x) so I
didn't research this any further but tried to build from source

So i cloned:

git clone git://anongit.kde.org/digikam-software-compilation dk

installed deps:

> sudo port -v install qt4-mac +debug
> sudo port -v install qt4-mac-sqlite3-plugin +debug
> sudo port -v install kdelibs4 +debug
> sudo port -v install kde4-baseapps +debug
> sudo port -v install opencv +debug
> sudo port -v install marble +debug
> sudo port -v install oxygen-icons +debug
> sudo port -v install sane-backends +debug
> sudo port -v install libgpod +debug
> sudo port -v install libgphoto2 +debug
> sudo port -v install lensfun +debug
> sudo port -v install liblqr +debug

> ./download-repos
> ./bootstrap.macports

This seemed to go OK:

"--  digiKam can be compiled.................. YES"

make install

which also succeeds and

sudo make install/fast

I then also ran:

> launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
> /opt/local/bin/kbuildsycoca4

Now it crashes with another failure. See attached log for 4.2.

I guess the most relevant part is the main thread:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib         0x00007fff8a29f0c2 close + 10
1   libkdeui.5.dylib               0x000000010fb2bec7
KCrash::defaultCrashHandler(int) + 247
2   libsystem_platform.dylib       0x00007fff92c6c5aa _sigtramp + 26
3   ???                           000000000000000000 0 + 0
4   libsystem_c.dylib             0x00007fff894c7b1a abort + 125
5   QtCore                         0x000000011111112b
qt_message_output(QtMsgType, char const*) + 203
6   QtCore                         0x00000001111113c9
qt_message(QtMsgType, char const*, __va_list_tag*) + 409
7   QtCore                         0x0000000111110caf qFatal(char
const*, ...) + 159
8   QtGui                         0x0000000110164786
QWidgetPrivate::QWidgetPrivate(int) + 774
9   QtGui                         0x00000001104ccf73
QFramePrivate::QFramePrivate() + 19
10  QtGui                         0x000000011054f8fe
QAbstractScrollAreaPrivate::QAbstractScrollAreaPrivate() + 14
11  QtGui                         0x0000000110554645
QScrollArea::QScrollArea(QWidget*) + 37
12  digikam                       0x000000010ba4e3be
Digikam::AssistantDlgPage::AssistantDlgPage(KAssistantDialog*, QString
const&) + 46 (assistantdlgpage.cpp:65)
13  digikam                       0x000000010ba4ef8a
Digikam::WelcomePage::WelcomePage(KAssistantDialog*) + 106
14  digikam                       0x000000010ba4ef0d
Digikam::WelcomePage::WelcomePage(KAssistantDialog*) + 29
15  digikam                       0x000000010ba4dcac
Digikam::AssistantDlg::AssistantDlg(QWidget*) + 300
16  digikam                       0x000000010ba4db6d
Digikam::AssistantDlg::AssistantDlg(QWidget*) + 29
17  digikam                       0x000000010baa9511 main + 5169 (main.cpp:148)
18  libdyld.dylib                 0x00007fff92d0f5fd start + 1

I probably don't correctly understand the instructions and miss some
dependency or something.

Any help is highly appreciated!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: digikam crash on startup
Type: application/octet-stream
Size: 63102 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20140802/8b66d0c9/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: digiKam 4.2 crash
Type: application/octet-stream
Size: 64410 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20140802/8b66d0c9/attachment-0001.obj>

More information about the Digikam-users mailing list